all in all uva exercise

Iniciado por + 1 Oculto(s), 15 Julio 2016, 03:37 AM

0 Miembros y 1 Visitante están viendo este tema.

+ 1 Oculto(s)

Citar
You have devised a new encryption technique which encodes a message by inserting between its characters
randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
detail how the strings are generated and inserted into the original message. To validate your method,
however, it is necessary to write a program that checks if the message is really encoded in the final
string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
characters separated by whitespace. Input is terminated by EOF.
Output
For each test case output, if s is a subsequence of t.
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No


y este es mi codigo, no se como solucionarlo, no funciona para todos los casos


Código (java) [Seleccionar]
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.StringTokenizer;

/**
* a->97 z->122 A->65 A->90
*
* @author qwery.azc
*/
public class Main {

   public String pertenecer(String cadenita, String cadenota) {
       int piv = 0;
       int cajaIndex=0;
       String res="No";
       for (int i = 0; i < cadenita.length(); i++) {
           char caracter=cadenita.charAt(i);
           for (int j = 0; j < cadenota.length() ; j++) {
               if (caracter == cadenota.charAt(j)) {
                   piv++;
                   i++;
                   
               }
               
           }
       }
       if(piv==cadenita.length()){
           res="Yes";
       }
       System.out.println(res);
       return res;
   }

   public static void main(String argumentos[]) throws IOException {
       Main m = new Main();
        StringTokenizer stk;
        String line;
        String cad1,cad2;
       BufferedReader  scanner = new BufferedReader(new InputStreamReader(System.in));
       while ((line=scanner.readLine())!=null) {
           stk=new StringTokenizer(line," ");
          cad1=stk.nextToken();
          cad2=stk.nextToken();
          m.pertenecer(cad1, cad2);
       }
     
       scanner.close();
   }
   }


aqui va la solucion, pero lo adapto y no da nada

http://solvingproblemsbd.blogspot.com/2014/09/uva-solution-10340-all-in-all.html

TheAIRXX

Según yo he entendido el problema he encontrado esos fallos. Y a mi me funciona. De todas maneras, se puede programar de una manera bastante más eficiente, aunque como es un problema pequeño no importa demasiado.
Espero que te ayude.
Un saludo

Código (java) [Seleccionar]

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.StringTokenizer;
import java.util.NoSuchElementException;

/**
* a->97 z->122 A->65 A->90
*
* @author qwery.azc
*/
public class Main {

    public String pertenecer(String cadenita, String cadenota) {
        int piv = 0;
        int cajaIndex=0;
        String res="No";
        for (int i = 0; i < cadenita.length(); i++) {
            char caracter=cadenita.charAt(i);
            for (int j = 0; j < cadenota.length() ; j++) {
                if (caracter == cadenota.charAt(j)) {
                    piv++;
                    break;  //Si incrementas la i este bucle sigue y ya no es necesario porque ha encontrado el caracter.

                }

            }
        }
        if(piv==cadenita.length()){
            res="Yes";
        }
        System.out.println(res);
        return res;
    }

    public static void main(String argumentos[]) throws IOException {
        Main m = new Main();
         StringTokenizer stk;
         String line;
         String cad1,cad2;
        BufferedReader  scanner = new BufferedReader(new InputStreamReader(System.in));
        while ((line=scanner.readLine())!=null) {
           stk=new StringTokenizer(line," ");
           try { //Tienes que usar un try/catch para capturar la excepcion que se lanza cuando stk se queda vacio.
           cad1=stk.nextToken();
           cad2=stk.nextToken();
            }catch(NoSuchElementException e){
                break;
            }
           m.pertenecer(cad1, cad2);
        }

        scanner.close();
    }
}

+ 1 Oculto(s)

hice la prueba de tu codigo y sale de respuesta lo siguiente
CitarYes
Yes
Yes
No

pero la respuesta deberia ser :

Citar
Yes
No
Yes
No

saludos... y gracias por colaborar

overxfl0w13

Estáis planteando mal el problema.

Se puede resolver con coste lineal llevando dos pivotes sobre s y t, avanzando solo el índice de s si el elemento coincide con el ítem a comprobar de t.


http://pastebin.com/hHcL5cEz


El juez lo acepta.

Saludos :).
[/url]

+ 1 Oculto(s)

si funciona gracias, lo adapte a mi codigo!!!